Hallo und willkommen in unserer Community! Ist dies Dein erster Besuch?
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 23
  1. #1
    Tierischer S-Mod
    Avatar von Miese.Ratte
    Registriert seit
    13.10.2013
    Beiträge
    17.380
    DankeAktivitätenReceiverTagging

    eyetvCamd 64bit

    Ein Freund von mir ist Macianer und begeisterter Fan der TV-Software EyeTV. Für EyeTV gibt es eine Software von Tobias Feigl, die dessen Anschluss an einen Cardserver wie OSCam ermöglicht.

    Link nur für registrierte und freigeschaltete Mitglieder sichtbar.

    Diese Software tut das, was fast alle alten Module tun. Sie ruiniert 64-Bit-Controlwords, wie sie von SkyDE seit Mitte April verwendet werden. Das war doof.

    Die gute Nachricht war, dass der Quellcode auf GitHub zur Verfügung steht. Da issie:
    Link nur für registrierte und freigeschaltete Mitglieder sichtbar.

    Im eyetvCamd gab es sogar zwei Stellen, die 64-Bit-Controlwords töteten:
    Code:
    The first culprit is in eyetvCamd/cwdwplug/Controller.mm, line 130:
    dw->dw[i+3] = dw->dw[i] + dw->dw[i + 1] + dw->dw[i + 2];
    
    A second culprit is in eyetvCamd/eyetvCamd/Controller.mm, lines 800-806:
    if( legacyDW == false )
    {
        dw[3] = dw[0] + dw[1] + dw[2];
        dw[7] = dw[4] + dw[5] + dw[6];
        dw[11] = dw[8] + dw[9] + dw[10];
        dw[15] = dw[12] + dw[13] + dw[14];
    }
    Catch it! Kill it! Bin it! :-)
    Nach einem mittelschweren Kampf mit XCode und dessen ungewohnten Eigenheiten fiel das heraus:
    Link nur für registrierte und freigeschaltete Mitglieder sichtbar.

    Damit leuchtet der Himmel wieder.

    (Die Voraussetzung ist selbstverständlich ein Cardserver mit 'ner hellen Karte.)
    Einfach nur schöner fernsehen. "Geht nicht" gibt's nicht.

    •   Alt Advertising

       

  2. #2
    Anfänger

    Registriert seit
    23.11.2015
    Beiträge
    3
    DankeAktivitätenReceiverTagging
    du bist grad mein Held des Tages! Ach was sag ich der letzten 2 Monate!

    HAAAAMMMEEERRRR, H, A, doppel M, E, R!
    Geändert von sturze (27.05.2019 um 18:49 Uhr)

  3. #3
    Anfänger

    Registriert seit
    18.08.2014
    Beiträge
    8
    DankeAktivitätenReceiverTagging
    Du bist mein Held!!!!! Vielen Dank!

  4. #4
    Anfänger

    Registriert seit
    06.07.2016
    Beiträge
    1
    DankeAktivitätenReceiverTagging

    EyetvCamd für EyeTV 4 und Ost 10.15

    Hallo, vielen Dank für die 64bit-Variante. Leider "läuft" diese aber bei mir nicht unter osx 10.15 und Eyetv 4. Gibt es Rat oder ein Update?
    Herzliche Grüße
    Elvis

  5. #5
    Tierischer S-Mod
    Themenstarter
    Avatar von Miese.Ratte
    Registriert seit
    13.10.2013
    Beiträge
    17.380
    DankeAktivitätenReceiverTagging
    Es gibt derzeit nur einen Rat. Nimm das ältere EyeTV und lass Catalina links liegen. Das ältere EyeTV ist 32-bittig und passt damit zum Plugin. Beide müssen nämlich die gleiche Architektur benutzen.

    Ein Update kannst du dir sonst auch selber backen. Die Zutaten sind Open Source und die erfolgten Änderungen im ersten Beitrag aufgeführt.
    Einfach nur schöner fernsehen. "Geht nicht" gibt's nicht.

  6. #6
    Anfänger

    Registriert seit
    23.11.2015
    Beiträge
    3
    DankeAktivitätenReceiverTagging
    Zitat Zitat von Miese.Ratte Beitrag anzeigen
    Es gibt derzeit nur einen Rat. Nimm das ältere EyeTV und lass Catalina links liegen. Das ältere EyeTV ist 32-bittig und passt damit zum Plugin. Beide müssen nämlich die gleiche Architektur benutzen.

    Ein Update kannst du dir sonst auch selber backen. Die Zutaten sind Open Source und die erfolgten Änderungen im ersten Beitrag aufgeführt.
    Mir gehts grad ähnlich. Keine Ahnung wie ich das "gebacken" bekomm. Kann mir/uns wer helfen?

  7. #7
    Tierischer S-Mod
    Themenstarter
    Avatar von Miese.Ratte
    Registriert seit
    13.10.2013
    Beiträge
    17.380
    DankeAktivitätenReceiverTagging
    An dieser Stelle gibt es Unklarheiten.

    Auf meinem MacBook läuft kein Catalina. Das Gerät ist dafür zu alt. Ein neues werde ich mir deshalb ganz bestimmt nicht kaufen. Es ist technisch nach wie vor top. Fu** you, Apple!

    Deshalb bin ich auf eure Ansagen ein wenig angewiesen.

    Ab Catalina laufen nur noch 64-bit-Anwendungen. Damit fällt das alte EyeTV von Elgato flach. Der neue Besitzer von EyeTV hat eine 64-Bit-Anwendung herausgegeben. Angeblich verfügt die über keine Plugin-Schnittstelle mehr. Ist das so?
    Einfach nur schöner fernsehen. "Geht nicht" gibt's nicht.

  8. #8
    Anfänger

    Registriert seit
    23.11.2015
    Beiträge
    3
    DankeAktivitätenReceiverTagging
    Zitat Zitat von Miese.Ratte Beitrag anzeigen
    An dieser Stelle gibt es Unklarheiten. Auf meinem MacBook läuft kein Catalina. Das Gerät ist dafür zu alt. Ein neues werde ich mir deshalb ganz bestimmt nicht kaufen. Es ist technisch nach wie vor top. Fu** you, Apple! Deshalb bin ich auf eure Ansagen ein wenig angewiesen. Ab Catalina laufen nur noch 64-bit-Anwendungen. Damit fällt das alte EyeTV von Elgato flach. Der neue Besitzer von EyeTV hat eine 64-Bit-Anwendung herausgegeben. Angeblich verfügt die über keine Plugin-Schnittstelle mehr. Ist das so?
    Hab selbst noch keine Ahnung. Den Ordner Plugins gibts nicht nach der Installation. Soll aber erstmal nichts heißen denk ich. Hab schon eine Mail an den Support geschrieben, was mit der FB des EyeTV tuners ist (war nämlich auch immer ein Plugin). Hoffe ich bekomm da bald was, sonst klopf ich da mal telefonsich auf den Busch! Gekostet hat das Update ja auch, dann darf mir der Support auch antworten. Ich halt dich mal auf dem Laufenden, sobald ich was hab. Danke vorweg fürs kucken.

  9. #9
    Anfänger

    Registriert seit
    14.08.2015
    Beiträge
    7
    DankeAktivitätenReceiverTagging
    Hallo, ich bekomme es irgendwie nicht zum laufen, vielleicht kann mir jemand hier helfen.
    Ich habe die Applikation kopiert, aber was noch viel wichtiger ist, ich habe das Plug -In in den eyeTV plugins.

    Beim start des eyetvcamd kommt die Meldung dass ihm die SoftCam.key fehlt ? Wenn ich irgendeine nehme,
    kommen sehr viele Fehler, ich denke mit dem @ kann es nichts anfangen.
    Wenn ich dann meine Server eintrage muss ich noch "Enable EMU" drücken oder ?
    Ich bekomme im Log denn die Meldung
    [core.auExtern] triggert from findkey (N 00FC 00)
    [core.ecm] system: no key found for N 00FC 00

    rechts bei CAID/IDENT/PID habe ich einträge, allerdings ist die IDENT überall 000000 - vielleicht kann mir jemand kurz helfen

    VG Goofy

  10. #10
    Tierischer S-Mod
    Themenstarter
    Avatar von Miese.Ratte
    Registriert seit
    13.10.2013
    Beiträge
    17.380
    DankeAktivitätenReceiverTagging
    Wo kommt wann welche Meldung heraus?

    Die IDENT kann durchaus 000000 sein. Nicht jedes Verschlüsselungssystem braucht die.
    Einfach nur schöner fernsehen. "Geht nicht" gibt's nicht.

  11. #11
    Anfänger

    Registriert seit
    14.08.2015
    Beiträge
    7
    DankeAktivitätenReceiverTagging
    Ich starte die Version 2.0b2 dann kommt folgendes

    camd3: connected to server egygold.co:11000
    [general.error] failed open /Users/goofy/Documents/eyetvCamd/SoftCam.Key: No such file or directory
    [general.error] no keys loaded for softcam!
    [core.load] ** registered systems:
    [core.load] ** Seca (pri -10)
    [core.load] ** Irdeto (pri -10)
    [core.load] ** Cryptoworks (pri -10)
    [core.load] ** ConstCW (pri -20)
    [core.load] ** Conax (pri -10)
    [core.load] ** Nagra2 (pri -10)
    [core.load] ** Nagra (pri -10)

    und wenn ich dann eyeTV starte kommt das


    cwdwplug: ServiceChanged:
    cwdwplug: Active PID: 0, type: 9
    cwdwplug: Active PID: 21, type: 2
    cwdwplug: Active PID: dc, type: 5
    cwdwplug: Active PID: 205, type: 5
    cwdwplug: Active PID: 206, type: 5
    cwdwplug: Active PID: 207, type: 5
    cwdwplug: Active PID: 208, type: 5
    cwdwplug: Active PID: 19ce, type: 5
    cwdwplug: Active PID: 1ace, type: 5
    cwdwplug: Active PID: 1bce, type: 5
    cwdwplug: Active PID: 1cce, type: 5
    cwdwplug: Active PID: 1ece, type: 5
    cwdwplug: Active PID: 1fce, type: 5
    cwdwplug: Active PID: 1fcf, type: 5
    cwdwplug: Active PID: 1fd0, type: 5
    cwdwplug: Active PID: 203, type: 6
    cwdwplug: Active PID: 1ff, type: d
    cwdwplug: Active PID: 31, type: e
    cwdwplug: Active PID: 61, type: 4
    cwdwplug: Active PID: 1ff, type: 3
    cwdwplug: Active PID: 11, type: 9
    cwdwplug: Active PID: 12, type: 9
    cwdwplug: Active PID: 14, type: 9
    cwdwplug: Active PID: 13, type: 9
    cwdwplug: plugin terminated
    cwdwplug: plugin initialized
    cwdwplug: GetInfo
    cwdwplug: Device with id 101 and Index = 0 added
    cwdwplug: service change API called: globals = 0x7a905000, deviceid = 101
    cwdwplug: pidsCount changed from 0 to 24
    cwdwplug: ServiceChanged:
    cwdwplug: Active PID: 0, type: 9
    cwdwplug: Active PID: 21, type: 2
    cwdwplug: Active PID: dc, type: 5
    cwdwplug: Active PID: 205, type: 5
    cwdwplug: Active PID: 206, type: 5
    cwdwplug: Active PID: 207, type: 5
    cwdwplug: Active PID: 208, type: 5
    cwdwplug: Active PID: 19ce, type: 5
    cwdwplug: Active PID: 1ace, type: 5
    cwdwplug: Active PID: 1bce, type: 5
    cwdwplug: Active PID: 1cce, type: 5
    cwdwplug: Active PID: 1ece, type: 5
    cwdwplug: Active PID: 1fce, type: 5
    cwdwplug: Active PID: 1fcf, type: 5
    cwdwplug: Active PID: 1fd0, type: 5
    cwdwplug: Active PID: 203, type: 6
    cwdwplug: Active PID: 1ff, type: d
    cwdwplug: Active PID: 31, type: e
    cwdwplug: Active PID: 61, type: 4
    cwdwplug: Active PID: 1ff, type: 3
    cwdwplug: Active PID: 11, type: 9
    cwdwplug: Active PID: 12, type: 9
    cwdwplug: Active PID: 14, type: 9
    cwdwplug: Active PID: 13, type: 9
    cwdwplug: HeadendID: c0, TransponderID: a5497a, ServiceID: ef11, PMT pid: 61
    [nagra.ecm] bad ECM message msgLen=-1 sctLen=200

    Link nur für registrierte und freigeschaltete Mitglieder sichtbar.

    Wenn ich dann rechts auf eine andere CAID klicke kommt folgendes

    [core.auExtern] triggered from findkey (N 00B0 M1)
    [nagra.key] missing 00b0 M1 key
    [core.auExtern] triggered from findkey (N 00B0 00)
    [core.ecm] system: no key found for N 00B0 00
    [core.auExtern] triggered from findkey (N 000F M1)
    [nagra.key] missing 000f M1 key
    [core.auExtern] triggered from findkey (N 000F 01)
    [core.ecm] system: no key found for N 000F 01
    ..
    .
    .
    Geändert von goofy79 (03.04.2020 um 17:17 Uhr)

  12. #12
    Tierischer S-Mod
    Themenstarter
    Avatar von Miese.Ratte
    Registriert seit
    13.10.2013
    Beiträge
    17.380
    DankeAktivitätenReceiverTagging
    Das hat mit der 64bit-Variante gar nichts zu tun. Die brauchst du für die Werbesender gar nicht. Mit den Sendern funktioniert bereits das Original.

    Deine Installation liefert keine intakten ECMs. Hast du einen Tuner mit Modul? Steckt das da noch drin? Welches EyeTV hast du?
    Einfach nur schöner fernsehen. "Geht nicht" gibt's nicht.

  13. #13
    Anfänger

    Registriert seit
    14.08.2015
    Beiträge
    7
    DankeAktivitätenReceiverTagging
    Ich nutze die aktuelle eyeTV 3.6.9 (7528) und die über eine eyeTV Netstream

    Das kommt zB bei einem Sky Sender
    Link nur für registrierte und freigeschaltete Mitglieder sichtbar.
    Geändert von goofy79 (03.04.2020 um 17:29 Uhr)

  14. #14
    Tierischer S-Mod
    Themenstarter
    Avatar von Miese.Ratte
    Registriert seit
    13.10.2013
    Beiträge
    17.380
    DankeAktivitätenReceiverTagging
    Du hast die EMMs eingeschaltet. Das ist keine Standardeinstellung. Es sorgt aber nicht für die hier beschriebene Fehlfunktion.

    Es gibt "Log CW/DW". Schalte das an und zeige das Ergebnis.
    Einfach nur schöner fernsehen. "Geht nicht" gibt's nicht.

  15. #15
    Anfänger

    Registriert seit
    14.08.2015
    Beiträge
    7
    DankeAktivitätenReceiverTagging
    da kommt folgendes
    Link nur für registrierte und freigeschaltete Mitglieder sichtbar.
    bzw wenn ich umschalte
    Link nur für registrierte und freigeschaltete Mitglieder sichtbar.

    aber die SoftCam.key hat nichts damit zu tun ? Weil die zeigt er ja beim start an, dass die fehlt ?
    Geändert von goofy79 (04.04.2020 um 16:47 Uhr)


 
Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. Windows 10 32Bit auf 64Bit upgraden
    Von maddin-la im Forum Betriebssystem WINDOWS 10
    Antworten: 2
    Letzter Beitrag: 15.01.2017, 09:57
  2. Problem mit altem Programm unter 64Bit
    Von maddin-la im Forum Betriebssystem WINDOWS 10
    Antworten: 2
    Letzter Beitrag: 15.12.2016, 17:21
  3. Antworten: 6
    Letzter Beitrag: 19.04.2016, 22:19
  4. Antworten: 12
    Letzter Beitrag: 14.08.2015, 13:16
  5. Win 7 64Bit und amilo?
    Von franzli im Forum Betriebssystem WINDOWS 7
    Antworten: 4
    Letzter Beitrag: 17.03.2015, 22:13

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
 Nachtfalke Reloaded Aktuell betrachtest Du unsere Community als Gast und hast somit nur begrenzten Zugriff auf Diskussionen, Bereiche und Downloads.
Registriere dich noch heute um auf alle Bereiche zuzugreifen!